sábado, 17 de novembro de 2007

Ubuntu lança atualização "bugada" do Samba

Quem usa o Samba com Ubuntu Dapper (6.06) e atualizou os pacotes ontem deve ter passado por uma surpresa bem desagradável.

A atualização liberada (3.0.22-1ubuntu3.4) estava bugada e a autenticação no domínio usando máquinas Windows parou de funcionar.

Logo após ao meio-dia (horário de Brasília) os pacotes foram removidos, mas aí já era pra muita gente.

A solução encontrada naquele momento foi fazer o downgrade pra versão anterior (3.0.22-1ubuntu3.3) para que tudo voltasse a funcionar.

Consultei hoje e já percebi que saiu uma nova versão (3.0.22-1ubuntu3.5), mas ainda não tive como testar. Segunda eu vejo.

Se alguém já testou, poste seus comentários.

Espero que o pessoal do Ubuntu tenha mais cuidado com essas coisas. Já é a segunda vez em pouco mais de 1 ano que eles lançam pacotes problemáticos.

Boa sorte para nós. :-)

UPDATE (19/11) : Segue a URL do bug.